Unavailability of "classic" StartMail
Incident Report for StartMail
Resolved
The classic webmail should be available again. You may also have experienced issues in accessing email in the new web interface, with an error message shown "Unable to load messages". This should be resolved by now.
Posted Mar 03, 2021 - 17:21 UTC
Investigating
It is not possible right now to access classic StartMail webmail. Our engineers are looking into the cause of this issue and possible solutions. As a workaround, you can access your mail through the modern StartMail webmail through https://mail.startmail.com/
Posted Mar 03, 2021 - 15:41 UTC
This incident affected: Webmail.