Problems processing credit card payments
Incident Report for StartMail
Resolved
We worked out the issues with our payment service provider and as a result credit card payment processing is now resumed.

Charges that failed in the last 24 hours will be automatically retried so no action is required for users.
Posted Oct 29, 2019 - 18:48 UTC
Identified
We are currently unable to process credit card payments due to problems with our payment provider. We are on the case doing all we can and we expect credit card payments to be resumed later today. As a work-around users can still use PayPal which is up and running normally.
Posted Oct 29, 2019 - 10:44 UTC
This incident affected: Webmail.