DDoS attack
Incident Report for StartMail
Resolved
The attack appears to be over. We keep monitoring the situation.

N.B. Please note that a DDoS attack means our network connections are flooded with traffic and this does not include any compromise of user data.
Posted Oct 11, 2021 - 06:03 UTC
Identified
We're currently experiencing what appears to be a DDoS attack (again) and collaborating with our ISP to mitigate. Users may experience slow response rates or complete unavailability of the webmail service.

We're sorry for the inconvenience this may cause.
Posted Oct 11, 2021 - 04:16 UTC
This incident affected: Website, Webmail, Mail access (IMAP), and Mail delivery (SMTP).