Degraded performance
Incident Report for StartMail
Resolved
This incident has been resolved.
Posted Mar 23, 2024 - 20:29 UTC
Monitoring
All services are up again. Performance may be slightly degraded for a few minutes. We are monitoring closely.
Posted Mar 23, 2024 - 20:14 UTC
Identified
We identified the problem, one of our servers got hung up and needed to be rebooted. We are bringing services back online for affected users.
Posted Mar 23, 2024 - 20:12 UTC
Investigating
We are currently investigating an issue with one of our servers. Some users may not be able to log in at the moment and performance is degraded.
Posted Mar 23, 2024 - 19:55 UTC
This incident affected: Webmail, Mail access (IMAP), and Mail delivery (SMTP).