Issues with subscription system and payment gateway
Incident Report for
StartMail
Resolved
This incident has been resolved.
Posted
Oct
20
,
2025
-
14:54
UTC
Identified
Our subscription system and payment gateway are currently encountering technical issues. You may experience difficulties in accessing your subscription status, managing payment methods, or signing up for a new account.
Posted
Oct
20
,
2025
-
10:09
UTC
This incident affected: Webmail.
×
Subscribe to Incident
Subscribe to updates for
Issues with subscription system and payment gateway
via . You'll receive .