Sign up unavailable

Incident Report for StartMail

Resolved

This incident has been resolved.
Posted Dec 15, 2024 - 17:28 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 15, 2024 - 14:57 UTC

Investigating

Since today December 15, 10:00 CEST / 4:00am EST we are observing errors on the creation of new vaults. This shows as an error "Your account could not be created" during the sign up for StartMail or when creating a new account in a group subscription.

Existing vaults and customers are unaffected.

We're investigating the cause for this failure. Please come back later to sign up and we hope to welcome you as a StartMail customer soon.
Posted Dec 15, 2024 - 13:59 UTC
This incident affected: Webmail.