General outage

Incident Report for StartMail

Resolved

This incident has been resolved.
Posted Jun 21, 2025 - 16:01 UTC

Monitoring

We have deployed a fix around 15:53 UTC which should enable the remaining users to log in to their account as well. We're monitoring the situation. Please contact support in case you still experience issues.
Posted Jun 21, 2025 - 15:53 UTC

Identified

Some of our users may still be unable to access their email as we were recovering the storage service. We're continuing to work on a fix for the affected users.
Posted Jun 21, 2025 - 15:12 UTC

Monitoring

Servers have been rebooted and the service should be restored. We're monitoring the situation. Please contact support in case you still experience issues.
Posted Jun 21, 2025 - 14:49 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 21, 2025 - 14:21 UTC

Identified

We are suffering from a disruption on the storage server. Around 14:04 UTC some users started to experienced issues accessing their email. We are restarting the affected services to resolve the situation.
Posted Jun 21, 2025 - 14:21 UTC
This incident affected: Webmail, Mail access (IMAP), and Mail delivery (SMTP).