General outage
Incident Report for StartMail
Resolved
We suffered from a performance disruption. Between 14:00-14:25 UTC / 10:00-10:25 EDT users may have experienced issues accessing their email.

We were also not accepting incoming email for about 10 minutes in order to mitigate the increased load. Incoming email that was sent in those minutes typically gets re-sent within minutes and should all have been delivered by now.

We are very sorry for this unplanned interruption of service.
Posted Apr 13, 2023 - 14:41 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 13, 2023 - 14:24 UTC
Identified
We suffered from a short disruption on the storage server and a vault server. Around 14:02 UTC some users started to experienced issues accessing their email. We are restarting the affected services to resolve the situation.
Posted Apr 13, 2023 - 14:17 UTC
This incident affected: Webmail, Mail access (IMAP), and Mail delivery (SMTP).